Getting VS to remember TFS credentials

Dec 8, 2008 at 10:30 AM
Every time I load Visual Studio (before loading any solutions or TFS workspaces) I get prompted for my credentials to the Codeplex TFS servers. There is no "Remember my password" checkbox in the authentication form.

Is there any way to get VS or Codeplex to remember my password or not prompt me until I opt to load a solution located on the Codeplex TFS servers?

Thanks
Dec 8, 2008 at 8:48 PM
As far as I know Team Explorer does not currently have a "remember password" option.  Initially it tries the current AD credentials you are running Visual Studio under.  If this is a problem you could try one of our other source control clients.  Both SVN and Codeplex Client remember your creds.  Instructions are located here.
Dec 8, 2008 at 9:14 PM
I've just found a work-around (if not a solution) by twiddling around:

(Windows XP x64, domain-member computer, so I get the 'advanced' Users control panel)

Start > Settings > Control Panel > User Accounts > Advanced > Manage Passwords > Add

Server: tfs03.codeplex.com
Username: snd\W3bbo_cp
Password: yada

And hey-presto, no more prompts.

Is this 'feature' documentated anywhere? Maybe you should add it to the site's setup instructions.
Dec 11, 2008 at 5:38 AM
You may want to delete the above post since it contains your password. Or at the very least, change it :)
Dec 11, 2008 at 2:02 PM
Hi,

I'm using Vista and I've already tried your solution but it has never worked for me - I'm always prompted for my credentials.  I've added all servers from tfs01 to tfs04, for multiple projects, and I'm always prompted for each.

- Dave
Dec 11, 2008 at 3:34 PM
matthaw: that's not my real password :) Besides it doesn't meet the mimum length or complexity criteria required by Codeplex.

davedev: Hmm, that's odd. I'm guessing Vista's "Network Passwords" feature works differently to XP's. I'd file a bug on MSDN Connect.
Jan 30, 2009 at 5:52 AM
I tried W3bbo's solution in Vista 32bit and it works.  I had to add tfs05.codeplex.com.  

In vista, the option is called Manage network passwords.


HTH
Jan 31, 2009 at 9:37 PM
Just for clarification here's how to get it working on Vista:

Start -> Control Panel -> User Accounts -> Manage your network passwords

The "Manage your network passwords" is a link on the left in the tasks. Also, make sure when you're entering your credentials you leave "A Windows logon credential" selected. Even though you're connecting to a website the website credential selection will not work within Visual Studio. Also, it might help if you keep Visual Studio closed while you're doing this.
Feb 8, 2009 at 12:51 AM
jeff - I tried the method you suggested, and it still won't work.

Running Vista x64 SP1, visual studio 2008
Feb 10, 2009 at 2:38 PM
All I can say is make sure you have the latest service pack for Visual Studio and your machine is up to date on patches. If you're using a work machine to connect to it that might be a problem as well. I know my personal laptop has no problem remembering the credentials, but my work laptop won't even authenticate to the servers.
Aug 26, 2009 at 10:42 PM

Thanks so much for this info. I was looking for a way to fix this for a while. Works perfectly on windows 7. Add it as a Windows credential.

Feb 15, 2010 at 9:05 PM

Trying this out but it's not working for me.

It seems to be caused by running Vista Home edition.  The "A windows logon credential" radiobutton on the 'Stored Credential Properties" is grayed out, which is the option needed for this.

That used to be connected to a setting in the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa, DisableDomainCreds=0

But that registry entry is no longer effective since Aug 2009 software updates.

Anyone know of a way out of this ?  Other than swapping OS, that's not really an option for me at this point in time.

Feb 15, 2010 at 9:44 PM

I've recently added a third CodePlex project, which is on another server (tfs10) in addition to my existing projects (on tfs02 and tfs03). I've added the network credentials for tfs10 like I did for tfs02 and tfs03, but VS keeps giving me authentication popups.

Jun 6, 2010 at 8:17 AM
MaF wrote:

Thanks so much for this info. I was looking for a way to fix this for a while. Works perfectly on windows 7. Add it as a Windows credential.

Works perfectly for me too.

Add the server name: tfs01.codeplex.com, username: snd\username_cp and password: Password

Dec 11, 2010 at 3:39 PM

Thanks for info ! Works well on Win7 x64 (with server: tfs.codeplex.com).