Trouble starting a project

Feb 29, 2008 at 10:47 PM
I have had trouble with what I thought would be drop dead simple - uploading the first copy of the source into source control. I do ont wish to use the TFS client, so I tried TeamPrise which gave a JavaScript error on install. So, this is a CPC question, although suggesting another tool would be acceptable if that's what peopel are doing.

I'm not sure what the first thing to do is. There is no current souce code, so checking out seems silly, but I tried this and got an error. I then tried listing projects and got this error: It seemst hat I should start by being able to list projects and then proceed from there. Does anyone know why this is failing?

Microsoft Windows Version 6.0.6000
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\Kathleen\Current Projects\CodeGen\GenDotNet 2008>cpc listprojects kathl
Unhandled exception:
System.Configuration.ConfigurationErrorsException: Error creating the Web Proxy
specified in the '' configuration section.
at System.Net.Configuration.DefaultProxySectionInternal.GetSection()
at System.Net.WebRequest.get_InternalDefaultWebProxy()
at System.Net.HttpWebRequest..ctor(Uri uri, ServicePoint servicePoint)
at System.Net.HttpRequestCreator.Create(Uri Uri)
at System.Net.WebRequest.Create(Uri requestUri, Boolean useUriBase)
at System.Net.WebRequest.Create(Uri requestUri)
at System.Web.Services.Protocols.WebClientProtocol.GetWebRequest(Uri uri)
at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebRequest(Uri uri)

at System.Web.Services.Protocols.SoapHttpClientProtocol.GetWebRequest(Uri uri
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodN
ame, Object[] parameters)
at CodePlex.CodePlexClientLibrary.ProjectInfoWebSvc.ProjectInfoService.ListPr
ojectsForUser(String CodePlexUserName)
at CodePlex.CodePlexClientLibrary.CodePlexProjectInfoService.GetProjects(Stri
ng username)
at CodePlex.CodePlexClientLibrary.ListProjectsCommand.Execute()
at CodePlex.CodePlexClientLibrary.ApplicationBase`1.Run(DependencyContainer c
at CodePlex.CodePlexClientLibrary.ApplicationBase`1.Run()
System.Net.Sockets.SocketException: A socket operation encountered a dead networ
at System.Net.SafeCloseSocketAndEvent.CreateWSASocketWithEvent(AddressFamily
addressFamily, SocketType socketType, ProtocolType protocolType, Boolean autoRes
et, Boolean signaled)
at System.Net.NetworkAddressChangePolled..ctor()
at System.Net.AutoWebProxyScriptEngine.AutoDetector.Initialize()
at System.Net.AutoWebProxyScriptEngine.AutoDetector.get_CurrentAutoDetector()

at System.Net.AutoWebProxyScriptEngine..ctor(WebProxy proxy, Boolean useRegis
at System.Net.WebProxy.UnsafeUpdateFromRegistry()
at System.Net.WebProxy..ctor(Boolean enableAutoproxy)
at System.Net.Configuration.DefaultProxySectionInternal..ctor(DefaultProxySec
tion section)
at System.Net.Configuration.DefaultProxySectionInternal.GetSection()

C:\Users\Kathleen\Current Projects\CodeGen\GenDotNet 2008>
Mar 1, 2008 at 11:36 PM

I'm afraid I am not sure what the issue is with the CodePlex client. That said, sorry you had trouble with the Teamprise client as well. If you wanted to drop an email with details of the error we would love to try and help.

Could there be a firewall issue blocking outbound access to port 443 from the CodePlex client?

Sorry I'm not being much help,