Invalid ClickOnce zip file.

Aug 6, 2010 at 4:00 AM

I am sure this is something simple but I publish my solution, with setup.exe, application file and Application Files directory. Then in the folder containing the .application file I select all the files and create a zipfile.

The I create a release, give it a name and upload the zip file but I always get.

Invalid ClickOnce zip file. Please specify a valid Installation Folder URL (http://ggcstatus.codeplex.com/releases/clickonce/).

The URL I specify in VS matches exactly. 

Any ideas?

Aug 7, 2010 at 7:59 AM
Edited Aug 7, 2010 at 5:05 PM

Same problem...

I've followed the steps to the letter. The only thing I can think of is that my program name is not the same as my CodePlex project name.

There is nothing in the instructions that states the names of things need to match or what matches what so I'm left to figure it out on my own.

Any insight would be very much appreciated.

Aug 11, 2010 at 7:35 PM

strattronn & Malk0lm,

If you are still experiencing this issue can you contact us using this form: https://www.codeplex.com/site/contact

We can then get the package you are trying to upload and attempt to debug the issue.

Thanks,
-Colin

Aug 18, 2010 at 3:48 AM

Thanks to Matt H. I discovered I had set the Update option in the project properties to a different URL than the one I specified while building the project. Correcting that fixed the problem.

Aug 18, 2010 at 10:20 AM

Yes this fixed it for me as well. A little more explanation:

Install Mode and Settings should be "The Application is available offline as well(launchable from start menu)"

This makes the "Updates..." button show up

Click on "Updates..." button and set the "Update Location" to be the same as the "Installation Folder URL"

Roger

 

Aug 26, 2010 at 7:30 PM
colint wrote:

strattronn & Malk0lm,

If you are still experiencing this issue can you contact us using this form: https://www.codeplex.com/site/contact

We can then get the package you are trying to upload and attempt to debug the issue.

Thanks,
-Colin

I am still experiencing this problem even after modifying the updates settings.

I have used the contact form noted above and am waiting for further information.

Regards.

Aug 27, 2010 at 7:53 PM

We have identified an issue in our ClickOnce package validation logic: if your application / solution name has a space in it, it will be incorrectly report an invalid clickonce package.  We plan to have a fix for this deployed early next week, but in the mean time you can work around this issue by removing any spaces from your application name.

Thanks,
-Colin

Aug 31, 2010 at 4:05 PM

We deployed a fix for this issue yesterday afternoon. If you are still experiencing upload issues, please contact us to help you further.

Matt