Unable to Connect to Team Foundation Server : tfs01.codeplex.com

Aug 21, 2006 at 8:50 AM
I am trying to connect to TFS from my work this morning and it coming back with the error Unable to Connect to Team Foundation Server. I am not sure if its becoz of proxy at my work or is really the codeplex TFS is down, as i also did tried to ping the
tfs01.codeplex.com and the request is timing out so i am guessing its not the proxy at my work but possibly the server is down.

Please comment..

Thanks,
A..
Aug 22, 2006 at 3:03 AM
I think it must be something with your proxy because tfs01.codeplex.com hasn't been down at all. Have you been able to connect from home?
Sep 8, 2006 at 1:48 AM
I’m having the same trouble. I could connect from work yesterday morning (this connection does go via an ISA proxy) but not in the afternoon, I was getting a 407 Proxy Authentication required. However I can connect from home.... Strange.

At work I can hit http://tfs01.codeplex.com in IE, I get the prompt for my codeplex credentials, type that in and it lets me through (well it lets me thought to the 'Directory Listing Denied' which at least proves that I can get to tfs01.codeplex.com via my work proxy).

No sure what’s changed on my end, its as if VS Team Explorer is ignoring my internet connection settings, or perhaps Team explorer request via the proxy is not using my windows login credentials and therefore the proxy is denying it....

hummm...
Sep 14, 2006 at 3:02 AM
After some more investigation using fiddler (http://www.fiddlertool.com/fiddler/) I found out the following:

When connecting to tfs01.codeplex.com via IE fiddler notes 2 requests:

CONNECT tfs01.codeplex.com:443 HTTP/1.0
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322; .NET CLR 1.0.3705; .NET CLR 2.0.50727)
Host: tfs01.codeplex.com
Content-Length: 0
Proxy-Connection: Keep-Alive
Pragma: no-cache

And then:

CONNECT tfs01.codeplex.com:443 HTTP/1.0
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322; .NET CLR 1.0.3705; .NET CLR 2.0.50727)
Host: tfs01.codeplex.com
Content-Length: 0
Proxy-Connection: Keep-Alive
Pragma: no-cache
Proxy-Authorization: NTLM TlRMTblahblahblah….Q0V=

The data sent represents a SSLv3-compatible ClientHello handshake. For your convenience, the data is extracted below.

Major Version: 0
Minor Version: 0
Random: null
SessionID: null
Ciphers:
null


I’m guessing the proxy asks for authentication and the second request is IE providing that authentication.
(I first thought that the network administrators were blocking the CONNECT request method but they were not)

Then I tried to connect to tfs01.codeplex.com in visual studio. VS only produces the following request:

CONNECT tfs01.codeplex.com:443 HTTP/1.1
Host: tfs01.codeplex.com:443
Connection: Keep-Alive

It never provides the Proxy-Authorization header.

After some searching a similar problem with the VS help was noted here: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=73661&SiteID=1

Given that I thought Id try apply that fix to the devenv.exe.config and see what happens, it worked :)

Inside the system.net section of Program Files\Microsoft Visual Studio 8\Common7\IDE\devenv.exe.config I added a defaultProxy section as follows (note I also had to speify the port of my proxy, which may be different for you):

<system.net>
<settings>
<ipv6 enabled="true" />
</settings>
<defaultProxy enabled="true" useDefaultCredentials="true">
<proxy bypassonlocal="True" proxyaddress="http://myproxy:8080"/>
</defaultProxy>
</system.net>

Not sure at this point what other parts of VS this will affect but I’ll deal with that later. for now I can get to the codeplex TFS.....
Sep 14, 2006 at 4:56 AM
Nice! Thanks for passing the information along.