Commit Error

Jan 24, 2010 at 9:19 AM

I am new to SVN and am trying to commit my code. I get the following error when i do so:

 

Command: Commit  
Error: Commit failed (details follow):  
Error: Server sent unexpected return value (200 OK) in response to CHECKOUT request   
Error: for '/svn/!svn/vcc/default'  
Finished!:   

Command: Commit  

Error: Commit failed (details follow):  

Error: Server sent unexpected return value (200 OK) in response to CHECKOUT request   

Error: for '/svn/!svn/vcc/default'  

Finished!:   

Kindly let me know how to go about it.

 

Jan 24, 2010 at 2:08 PM

Same problem here.

Jan 24, 2010 at 3:29 PM

Can you clarify the structure of your repo? Was it
/trunk
/branches
/tags

Or did you just start uploading code at the root?

Jan 24, 2010 at 4:30 PM

Hi Matthaw, I have the structure you mentioned on my hard drive:

/trunk

/branches (even tried with branch)

/tags

Within trunk I have the following folders:

binaries, build, db, dependencies, docs, src.

Within src, i have a folder for my project and within that i have various other sub folders. I am right clicking and trying to commit the entire trunk folder.

Jan 24, 2010 at 4:34 PM

Thanks for the info. I've resolved the issue, so please try checking in again and letting us know if you continue to have problems.

Matt

Jan 24, 2010 at 4:52 PM

Thanks Matt for your prompt reply but i am getting the same error.

I followed the following steps this time:

1. Right click trunk - > Tortoise SVN - > Revert

2. Right click trunk - > Tortoise SVN - > Clean Up

3. Right click trunk - > SVN Commit

4. I selected the files I needed to check in. 

5. Clicked OK.

Jan 24, 2010 at 5:24 PM

Do you have any prior checkins? I'm able to create a new project and checkin successfully with the /trunk & source underneath.

Jan 24, 2010 at 5:38 PM

Nope, this would be the first checkin. Anyways, i will delete the entire folder and try again.

Jan 24, 2010 at 5:47 PM

I'm getting exactly the same error trying to commit to https://jgrmsts.svn.codeplex.com/svn, and I wonder if it might be related to Subversion/TortoiseSVN version; I'm having this problem with TortoiseSVN 1.6.7 (Subversion 1.6.9), which I installed yesterday evening, but never had this problem with TortoiseSVN 1.6.6 (Subversion 1.6.6) - right up to yesterday, just before I upgraded it.

Jan 24, 2010 at 5:51 PM

I too installed the latest version (TortoiseSVN 1.6.7) yesterday evening. Matt, are you also using this version?

Jan 24, 2010 at 6:02 PM
Edited Jan 24, 2010 at 6:03 PM

I've just downgraded TortoiseSVN to 1.6.6 (Subversion 1.6.6) and my commit went through perfectly - this has to be a TortoiseSVN 1.6.7 or Subversion 1.6.9 issue (either with them or CodePlex's SVNBridge). :(

Jan 24, 2010 at 7:23 PM

I also downgraded and its working fine for me now. Thanks everyone.

Jan 24, 2010 at 8:51 PM

Same as JamesRoss -- downgraded to 1.6.6 and now no error.

However, I did run into something... maybe just my relative new-ness to CodePlex, but I can't believe it takes this long for a branch/tag to show up.

I tried (twice) to create a branch/tag -- once from the HEAD, once from a specific version -- both times it appeared to create ok (no errors & normal message about WC not connected to the branch), BUT I see no changeset in CodePlex.

However, when I tried to create a 3rd tag set from the working copy, I get an error saying I have to update the WC --  and when I do it's 'updated' to a version that's non-visible in CodePlex and which doesn't show in the SVN repo browser either.

Nothing has shown up for about 3 hours now.  Any ideas?

Thanks,

 

David

Jan 24, 2010 at 10:36 PM

It does look like TortoiseSVN 1.6.7 is causing some issues with SVN Bridge on our end. We'll look into it this week. I rolled back our changes in SVN Bridge early this morning thinking that was the problem, but it doesn't look to be. Sorry for all the troubles.

Matt

Jan 25, 2010 at 11:41 PM

Hi all,

We have deployed a new version of SVN Bridge with a fix to address the SVN 1.6.9 changes. You should be able to commit now correctly.

Thanks for your patience and understanding,
Matt