Invisible Kanoodle BrightAds

Feb 18, 2007 at 5:08 PM
I followed the instructions here:

and now I see a link in the header above my project's wiki:

Why are these
ads here?

but there are no ads. Just a big empty area.

Here's the script that Kanoodle gave me (with the query string removed), which I pasted in the "Kanoodle BrightAds Code:" text box on my project's "Edit Project" page:

<SCRIPT language="JavaScript1.1" type="text/javascript" src=""></SCRIPT>
Feb 19, 2007 at 1:33 PM
what type of ads did you select? the first time i did it i selected an ad format but it didn't display anything on codeplex. Then i went back and selected a horizontal format and they displayed on codeplex.
Feb 19, 2007 at 4:58 PM
Hi camalot,

Thanks for the reply.

I followed the instructions in the article I cited to the tee. I selected "2 Ad Jumbo Leaderboard (754x90)". Just to be sure, I tried it again just now and I got the same result.

I thought that it may have something to do with being signed in (although, that is a feature I would like to have - not showing the ads while I'm signed in to my own project), but that doesn't seem to be the case.

I'm running Vista Business edition. I tried it, while signed in, using IE7 and then again, while not signed in, using Firefox and Opera. I didn't see the ads in any of them, but I did see a large blank area with the "Why are these ads here?" link in all of them. And, there is no "hand" cursor either, indicating that it's not just an invisibility issue.

Also, I do have scripting enabled in all of the aforementioned browsers.

I'd appreciate more ideas or advice from you or anyone else that think they might be able to help.

Feb 19, 2007 at 6:58 PM
I checked your project (it's, correct?) and it doesn't look like the ads are currently configured. I don't see the empty box or "why ads" link.

If you try configuring them again I can check it out to see if I can tell what's going on with it.

Thanks for your patience with this new feature, we're definitely interested in any feedback on how it works for people and the service received from Kanoodle.
Feb 19, 2007 at 8:07 PM
Edited Feb 19, 2007 at 8:08 PM
Hi jwanagel,

Yep, DocProject :)

I removed the ad so I wouldn't have a big blank space in the header. I put it back now so you can review it.

BTW, the style that I choose shouldn't matter, correct? (I don't mean the layout/bounds, just the appearance, such as "Blue Skies"). I tried with a couple different styles and it didn't seems to have any effect.

I really appreciate having this feature, so thank you for that.

And thanks for the help....
Feb 19, 2007 at 9:34 PM
The ads are showing up for me, so it looks like you configured it correctly. Are you located in the U.S. or somewhere else?

I know Kanoodle does not have a lot of advertisers outside of the U.S., so I'm wondering if what's happening is they are detecting your location by your IP address and don't have any ads to show for your location.
Feb 19, 2007 at 10:09 PM
I'm from New York City and I use a New York-based ISP, so I don't think that's it. Also, I only speak English so I don't think it's a localization issue.

If you need me to try some stuff on my end just let me know. Thanks.
Feb 20, 2007 at 6:32 PM
I wonder if it is something with your IP address, because I know Kanoodle uses your IP address to try and determine your location for better targeting.

What's your IP address? You can send it to us via the contact us form if you'd rather not post it.
Feb 20, 2007 at 8:06 PM
Ok, thanks. I just sent you my I.P. via the contact form, with some more information too.
Feb 20, 2007 at 8:30 PM
Has the url been approved by Kanoodle? I set up a project and added it to kanoodle, then added the code to the project page. the ads are not showing because kanoodle has not yet approved them for display. This may not be your problem but i thought it was worth mentioning to you as a possibility.
Feb 21, 2007 at 3:00 AM
Edited Feb 21, 2007 at 3:01 AM
Thanks camalot, but Kanoodle does say that it was approved.

I think jwanagel is correct about my IP being the problem since I tried viewing the ads on another computer that is behind the same router and it looks the same. i.e., big empty area and a "Why are these ads here?" link.

Sorry that I didn't think of checking that sooner :|
Feb 27, 2007 at 9:40 PM
I contacted Kanoodle, and they said the problem appears to be that they have an out of date IP database. They said they are working on it and it should be fixed soon.
Feb 28, 2007 at 6:51 AM
Great, thanks for your help.