W2008

Feb 25, 2009 at 4:30 PM
Hi,

Does the SLK-1.3.1 work with Windows 2008, and wss 3, I am having difficulty installing?

Thanks
David