TF31003 whilst connecting to codplex TFS

Feb 12, 2009 at 9:01 AM
Hi,

I'm new around here....

I'm getting that permission dialogue when I try to hook up my VS2008 system to CodePlex's system. Can somebody at CodePlex wield their magic and give me the necessary permissions?

Also, is TFS/VS2008 the preferred combination or do you think I should go down the SVN route? Which one would the average CodePlex'ian prefer?

Many thanks

Paul.
Feb 12, 2009 at 8:01 PM
This has been resolved.  You should be able to access TFS now.

And I'm not sure which source control client the average CodePlexer prefers but I believe the two most popular are Team Explorer and TortoiseSVN.

Thanks,
-Colin
Feb 12, 2009 at 9:49 PM
Hi Colin,

Many thanks, it's now sorted.
Mar 18, 2010 at 1:55 AM

Hi Colint, how was this resolved, I am facing the same issue, maybe caused by the fact that my account was just recently created?

Thanks,

Sergio

Mar 18, 2010 at 2:50 PM

Hi Sergio,

What is the project name you're trying to connect to?

Matt

Jul 2, 2010 at 12:23 AM

Hi matthaw, I am facing issue with mycollections project its at http://mycollections.codeplex.com/.

Jul 6, 2010 at 4:13 PM

Hi,

Sorry for the delay, it was a holiday weekend. Are you still having issues connecting?

Thanks,
Matt

From: smalugu [mailto:notifications@codeplex.com]
Sent: Thursday, July 01, 2010 5:24 PM
To: Matt Hawley
Subject: Re: TF31003 whilst connecting to codplex TFS [CodePlex:46910]

From: smalugu

Hi matthaw, I am facing issue with mycollections project its at http://mycollections.codeplex.com/.

Read the full discussion online.

To add a post to this discussion, reply to this email (CodePlex@discussions.codeplex.com)

To start a new discussion for this project, email CodePlex@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Jul 6, 2010 at 5:28 PM

I think I still have and the problem is how I am using Visual studio. The steps that I am doing in VS2010 are

Connect to team foundation server->Servers->Add->https://tfs06.codeplex.com->Submit->An authentication dialog popsup->Give my codeplex username/password (here I am not sure what domain should I give).

I saw some discussion about 2010 messing up with tfs and changed the settings accordingly. But if the above steps sound correct, I think I should look into settings again?

Aug 1, 2010 at 9:51 AM

I have the same issue, how to resolve it???

In vs2010,  i operate according to the steps:  Team Explorer, click button "Connect to Team Project", and then "Servers..."  --> "Add..."  --> enter https://tfs07.codeplex.com"  --> "ok",  enter my codeplex username/password,  and it show me:

TF31003: Either you have not entered the necessary credentials or your user account does not have permission to connect to the Team Foundation Server at https://tfs07.codeplex.com/. Click the Use different credentials link below, or ask your server administrator to add the appropriate permissions to your account.

 

but, i use my codeplex username/password to connect  https://aspnet.svn.codeplex.com/svn in TortoiseSVN,  it's ok.

 

Aug 1, 2010 at 8:04 PM

net205,

The correct creds to use with Team Explorer are:

Username: SND\net205_cp
Password: Your CodePlex Password

Thanks,
-Colin

Aug 1, 2010 at 9:39 PM

I also have the same issue. I am using VS2008 with Team Explorer.

Everything is properly setup. But I get error TF31002.

However, when I use it with my VS2010 it is working (no error).

What can I do to make my VS2008 working ?

Aug 2, 2010 at 5:50 AM

leihen,

To connect to a TFS2010 server with Team Explorer 2008, make sure:

a) You have the VS2008 SP1 & the Team Explorer 2008 forward compatibility pack installed
b) You connect to the full server path - https://tfs.codeplex.com/tfs/TFSXX

Thanks,
-Colin

Aug 2, 2010 at 4:52 PM

Colin,

thanks a lot. That was the missing information for me.

F.y.i: In the VS2008 TFS Add server dialog box (field servername) I had to enter the full path as given by you instead of providing only the servername. I used : https://tfs.codeplex.com:<port>/tfs/TFS02 for the servername. In the past I did not add the last part "TFS02".

Thanks again,

Henry

Aug 3, 2010 at 12:42 AM

Colin, thinks.

I have followed you to do, Not on the same connection:

Microsoft Visual Studio

TF31002: Unable to connect to this Team Foundation Server: https://tfs07.codeplex.com/.
Team Foundation Server Url: https://tfs07.codeplex.com/.
 
Possible reasons for failure include:
- The name, port number, or protocol for the Team Foundation Server is incorrect.
- The Team Foundation Server is offline.
- The password has expired or is incorrect.

Technical information (for administrator):
Unable to connect to the remote server

Aug 3, 2010 at 12:52 AM

net205,

TFS07 was migrated to TFS2010 today.  So:

a) Make sure you have the VS2008 SP1 & the Team Explorer 2008 forward compatibility pack installed
b) Connect to the new full server path - https://tfs.codeplex.com/tfs/TFS07

Thanks,
-Colin

Aug 3, 2010 at 6:44 AM
Edited Aug 3, 2010 at 9:01 AM

colint:
I used vs2010 to connect TFS above at home, and then return that messages.
Today, in company computer, vs2008 with sp1, and installed Team Explorer 2008 forward compatibility pack , then connected to TFS, the same error (TFS31003): http://docs.google.com/leaf?id=0B8bWB6LVC5R-NTk5Nzk1ZjctZTE3Ny00ZTg4LWJlNjgtMGNlMjBiNmI2Yjcw&hl=en

Thanks
-net205

Aug 3, 2010 at 6:49 AM

BTW:
I used Team Foundation Server and these accounts:
https://tfs07.codeplex.com, https://tfs.codeplex.com/tfs/TFS07,
net205/My CodePlex Password,  SND\net205_cp/My CodePlex Password
....

Aug 10, 2010 at 10:29 AM
I have exactly same problem, tried all different solutions to connect... but fails. (TF31003) (Client - Visual Studio 2010)
Aug 10, 2010 at 11:14 PM

MrWeiland,

Which project are you attempting to connect to?

Aug 11, 2010 at 8:52 AM
I'm connecting to Server Name: tfs.codeplex.com Path: tfs Port number: 443 Protocol: https Project Collection: TFS08
Aug 12, 2010 at 12:51 AM

MrWeiland,

The permissions look correct on our end.  Are you using your TFS username: SND\MrWeiland_cp ?

Aug 12, 2010 at 2:24 PM
Yes i do. I've tested all different ways to connect. I guess this is how it should look like.. https://tfs.codeplex.com/tfs/tfs08 But i get same error TF31003 - There must be something strange with my permissions on Team Foundation Server...
Aug 12, 2010 at 4:18 PM
MrWeiland wrote:
Yes i do. I've tested all different ways to connect. I guess this is how it should look like.. https://tfs.codeplex.com/tfs/tfs08 But i get same error TF31003 - There must be something strange with my permissions on Team Foundation Server...

I just sent you an email.  Can you reply back with a screenshot of what the add server dialog looks like when you enter that server path?

Thanks,
-Colin

Aug 13, 2010 at 1:08 PM
Done... :)
Aug 17, 2010 at 2:10 PM
Edited Aug 17, 2010 at 2:11 PM

I am having the same problem, i had connected earlier today but now for some reason I am getting TF31003, same user info and password, I have tried resetting my password.  The weird thing is I can connect fine through the Web UI if I browse manually to https://tfs.codeplex.com/tfs/ with the same credentials, it just doesn't seem to work through team explorer.

 

Edit: And now its back, I guess maybe just a little hiccup somewhere...

Aug 17, 2010 at 2:45 PM
I sent my screenshots to colint and i waiting and hoping he can help me... it's really annoying.
Aug 17, 2010 at 4:33 PM

I replied with some options to try.  Hopefully we can get this solved today.

Aug 17, 2010 at 5:57 PM
Hi

I will try this when i get to work sitting at a bad spot right now. So i get back to you in approx 15 hours.. :)

Best Regards

Tobias

2010/8/17 colint <notifications@codeplex.com>

From: colint

I replied with some options to try.  Hopefully we can get this solved today.

Read the full discussion online.

To add a post to this discussion, reply to this email (CodePlex@discussions.codeplex.com)

To start a new discussion for this project, email CodePlex@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Aug 18, 2010 at 6:32 AM
Hi

First with case sensitive didnt work but then i goto page to change password then it said that i have wrong password.....? So i sent for a new and added that and now it works fine... 

I'm nearly 100% sure that i had right password because i login to Codeplex rather often. What i can think of is that i use sometimes my MSN Live login most of the times and it's different from Codeplex login... 

So this is a user mistake i think.....as most of the times. 

Thank You for pointing me in right direction.

Tobias





2010/8/17 colint <notifications@codeplex.com>

From: colint

I replied with some options to try.  Hopefully we can get this solved today.

Read the full discussion online.

To add a post to this discussion, reply to this email (CodePlex@discussions.codeplex.com)

To start a new discussion for this project, email CodePlex@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Aug 18, 2010 at 6:35 AM
Edited Aug 18, 2010 at 6:37 AM
This was a user mistake that i had. I was using my Windows Live ID's password to login to codeplex and for some reason i used this to login to tfs when it should be my Codeplex password.... Rookie mistake. Change password https://www.codeplex.com/site/users/update Thank you Colint for helping me..
Aug 19, 2010 at 12:43 AM
paultyng wrote:

I am having the same problem, i had connected earlier today but now for some reason I am getting TF31003, same user info and password, I have tried resetting my password.  The weird thing is I can connect fine through the Web UI if I browse manually to https://tfs.codeplex.com/tfs/ with the same credentials, it just doesn't seem to work through team explorer.

 

Edit: And now its back, I guess maybe just a little hiccup somewhere...

Are you using Team Explorer 2008?  If so you will need to:

a) Make sure you have the VS2008 SP1 & the Team Explorer 2008 forward compatibility pack installed
b) Connect to the new full server path - https://tfs.codeplex.com/tfs/TFSXX

Thanks,
-Colin

Aug 25, 2010 at 12:54 PM

I am using 2010.  The problem is intermittent, many times its fine, but again this morning I'm getting the TF31003 problem.

Sep 3, 2010 at 6:36 PM

Getting it again today, although I can connect in Firefox to the web access.  Its just off and on still, I don't change any settings but it will stop working for a while, then come back after a while.

Sep 8, 2010 at 12:00 PM

When I go to the Issue Tracker in the site when I am getting problems in visual studio I get this:

 

"The Team Foundation Server is currently unavailable. Cannot view work item at this time."