Error pushing to Mercurial repository

May 29, 2013 at 9:46 PM
I’m trying to upload my initial codebase which I forked from another repository, but I can’t push it to my CodePlex Mercurial repository. The error I get is:
    abort: error: An existing connection was forcibly closed by the remote host
I first tried pushing the whole repository at once but doing so generated the error. I then tried pushing groups of changesets and successfully pushed around two thirds of them, but am stuck trying to push a single changeset which generates the above error. It gets up to sending 61696/88890 kb then crashes.

Is this a known problem? Is there are work-around?

May 30, 2013 at 6:36 PM
Are you still facing an issue? Unfortunately, our Mercurial support is not very reliable. On contrary, our Git support is very fast and reliable. You might also want to consider converting to git. By converting to git you will not lose the code, work items, issues and their history. You can work with git using a lot of tools, including the latest version of visual studio. Please send a request to us via the "Contact us" page ( and we will happy to convert it for you.
Jun 1, 2013 at 1:35 AM
While it is tempting to switch to Git, other projects related to mine all use Mercurial and things are simpler if I use Mercurial too. So I'll be sticking with Mercurial for now.

The issue has been resolved: Bashir, one of the CodePlex coordinators, contacted me and I gave him a Zip of my local repository which he then replaced my CodePlex repository with. Thank you Bashir!