TFS connection error: "The supplied email address is invalid. Parameter name: emailAddress"

Oct 11, 2012 at 1:35 PM
Edited Oct 11, 2012 at 1:36 PM

I got very strange error when tried to connect to TFS for the first time. Entered url into my VS2012 and get a error "Unable to connect to Team Foundation Server.....The remote server returned an error: (500) Internal Server Error".

Ok, I opened that TFS url in the browser to get more adequate error message, entered username and password, and I saw

The supplied email address is invalid.
Parameter name: emailAddress

What does it mean?

Codeplex svn connection always worked fine for me.

Oct 19, 2012 at 10:50 AM

Me too: "(500) Internal Server Error".

TFS doesn't work anymore for me :(

Oct 19, 2012 at 7:02 PM

Same here. And I checked my profile and a valid email address is on file. What's going on?

Nov 1, 2012 at 6:20 AM

Same here too.

Nov 15, 2012 at 11:54 AM

I get the same error.

i contact codeplex support but i didn't receive a response.

Nov 17, 2012 at 5:05 PM

I'm also getting the same error

Nov 19, 2012 at 7:58 PM

Are you trying to access a TFS project that you are not a developer or coordinator on?

Nov 19, 2012 at 9:10 PM

Yes, to download the sources. Isn't read-only access available for TFS?

Nov 19, 2012 at 9:14 PM

I tried to download some source projects that i'm not a member.

Nov 19, 2012 at 9:18 PM

Ok, it seems that is the problem.  Read-only access is not available for TFS projects.  It should say "access denied" instead of "email address is invalid", but it is a permissions issue.  To download the source code for a TFS project, you'll need to use the "Download" button on the Source Code tab.

Nov 19, 2012 at 9:22 PM

I receive the error when i click this button

Nov 20, 2012 at 9:46 AM

Thanks for letting us know.

But I must ask, if read-only access is not available for TFS projects, then why does the Connect link on the Source Code tab graciously offer a TFS link to non-members? It even tells you the username and password to use, as if you do have access. Nowhere does it say that you are not a member and so this link will never work for you. It's just setting you up to fail, especially since this is very similar to other code hosting sites where you do get a link to a read only source code repository. You should hide the link for non-members (or at least put a warning), instead of us banging our head on the wall trying to figure this out.

Also, any specific reason why read-only access is not available for TFS? I know the standalone version of TSF supports it.

Nov 20, 2012 at 10:37 PM

Thanks for the suggestion, we've modified the Connect dialog to let non-members know that only project members can access TFS.  TFS does support read-only permissions, unfortunately the security system isn't scalable enough to grant all CodePlex users read-only access to all projects.

Nov 21, 2012 at 8:28 AM

Perfectly solved. This discussion thread is now obsolete. Good job!