The project type is not supported by this installation when opening RI1\GlobalBank.Commercial.EBanking.sln

Jan 14, 2007 at 8:54 PM
After installing the Web Client Software Factory and its requirements (I think!) I tried to open up the reference application by opening the solution file RI1\GlobalBank.Commercial.EBanking.sln

I get the error:

---------------------------
Microsoft Visual Studio
---------------------------
The project file 'C:\Users\me\Documents\Visual Studio 2005\Projects\WCSF Source\RI1\UnitTest\Infrastructure\Infrastructure.Testing.UI.Tests\Infrastructure.Testing.UI.Tests.csproj' cannot be opened.

The project type is not supported by this installation.
---------------------------
OK Cancel Help
---------------------------





The same error occurs for the following projects as Visual Studio tries to open them as part of the solution

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\RI1\UnitTest\ElectronicFundsTransfer\ElectronicFundsTransfer.Module.Tests\ElectronicFundsTransfer.Module.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\RI1\UnitTest\Reports\Reports.Module.Tests\Reports.Module.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\Microsoft.Practices\CompositeWeb\UnitTest\CompositeWeb.Tests\CompositeWeb.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\Microsoft.Practices\PageFlow\UnitTests\PageFlow.Tests\PageFlow.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\Microsoft.Practices\PageFlow\UnitTests\PageFlow.Storage.EnterpriseLibrary\PageFlow.Storage.EnterpriseLibrary.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\Microsoft.Practices\PageFlow\UnitTests\PageFlow.WorkflowFoundation.Tests\PageFlow.WorkflowFoundation.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\Microsoft.Practices\ObjectBuilder.WCSFExtensions\UnitTests\ObjectBuilder.WCSFExtensions.Tests\ObjectBuilder.WCSFExtensions.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\Microsoft.Practices\WebControls\UnitTests\WebControls.Tests\WebControls.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\RI1\UnitTest\Shell\Shell.Module.Tests\Shell.Module.Tests.csproj'

'C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\RI1\UnitTest\Admin\Admin.Module.Tests\Admin.Module.Tests.csproj'

********************************************************************

When the project finally loads with these problems, I go to build it and get the errors

Error 103 Files has invalid value "obj\Debug\GlobalBank.Commercial.EBanking.Modules.ElectronicFundsTransfer.PageFlows.ElectronicFundsTransferPageFlow.layout". The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters. ElectronicFundsTransfer.Module

Message 1 Could not find schema information for the element 'http://schemas.microsoft.com/.NetConfiguration/v2.0:configuration'. C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\RI1\Source\Infrastructure\WebUI\Web.config 10 2 C:\...\WebUI\

Message 104 The maximum number of errors or warnings has been reached. C:\Users\declan.mcgrath\Documents\Visual Studio 2005\Projects\WCSF Source\RI1\Source\Infrastructure\WebUI\Web.config 192 1 C:\...\WebUI\

********************************************************************

P.S. I am following the instructions at the URL http://www.codeplex.com/websf/Wiki/View.aspx?title=Installing%20the%20Web%20Client%20Software%20Factory

P.P.S. I have followed all the default installation settings (ie. I haven't changed the path suggested by the installer).

Any help greatly appreciated. I am running Windows Vista with .NET installed and the
dll for the Workflow extensions has the product version 3.0.4203.2

Cheers,
hdb
Jan 14, 2007 at 11:40 PM

This forum is for CodePlex site issues only.

Please repost your question in one of the Web Client Software Factory forums:
http://www.codeplex.com/websf/Project/ListForums.aspx

Thanks,
Brad