Cannot connect to remote server error

May 1, 2012 at 11:16 AM

Until recently, we used a port number on our private nuget repo in the form using NuGet.Server. We recently updated DNS to remove the port number. We are running the latest 1.7 version of NuGet.Server.

Now, we can only view the list of dependencies. When we try to install a package, we get a "cannot connect to remote server error".

Steps taken to troubleshoot:

  • Reboot Windows and VS
  • Updated all configuration to point to the new URL without the port number
  • Flushed the DNS cache
  • Clear all the package history and cache
  • Searched the registry for any entries

I fired up Fiddler and was able to see the package list go to the correct URL without the port number, however, the install is still sending requests to the old URL with the port number. This is what Fiddler shows:

502 HTTP /api/v2/package/automapper/2.1.267

This explains the remote server connection error.

You can see this is going to the old URL for package installs. We verified all developers are having the same issue.

Is something being cached? I'm at a loss and need your assistance.