Unable to push file using tortoiseHg, authorization failed error

Oct 30, 2011 at 10:22 PM


Every time i try to push a file to my repository, the program doesn't allow it saying that the authorization failed


[command returned code 255 Sun Oct 30 22:13:37 2011]
DestructibleTextureDemo% % hg --repository C:\Users\Silva\Desktop\Repositories\DestructibleTextureDemo push https://hg01.codeplex.com/destructibletexture
pushing to https://hg01.codeplex.com/destructibletexture
searching for changes
abort: authorization failed


I have tried many times using my correct authentication, but it still won't work. Does any one know the solution?


Best reguards


Nov 1, 2011 at 10:38 PM

The problem was solved.

best regards


Nov 26, 2011 at 9:34 PM

I am getting this same error at atha.codeplex.com

Oct 2, 2012 at 3:41 AM
Edited Oct 2, 2012 at 3:42 AM


I've just started using Mercurial (two hours ago) and am facing exactly the same authentication problem.

How did you resolve the issue?

Here is the log output:

% hg --repository C:\Users\kalmurzayev\PMKS source code push https://hg.codeplex.com/pmksim
pushing to https://hg.codeplex.com/pmksim
searching for changes
http authorization required
realm: CodePlex
abort: authorization failed
[command returned code 255 Mon Oct 01 22:16:53 2012]

Oct 2, 2012 at 3:57 PM

@kalmurzayev - I've reset the permissions. Can you please try again?