New Project Redirects to

Apr 2, 2011 at 8:55 PM

Hi CodePlex Team,

I've just created a new project on CodePlex. I went through the wizard all the way to step (3) Done.  It told me that my publish deadline is May 2 2011.

However, I have not yet received any email confirmation and when I click on the "Go to your project" link or enter the project's URL into my browser it immediately redirects to the CodePlex home page:

I've created new projects before and there was never any wait time before I could see my project, so I'm just wondering if I have to wait longer now or if I've just inadvertently discovered an ugly CodePlex bug. :)


Apr 2, 2011 at 8:56 PM

BTW, the new project shows up under my account and it has a * to indicate that it's new.  Clicking the project link redirects to the CodePlex home page.

Apr 2, 2011 at 9:01 PM

I just received my email notification.  When I click the link in the email I'm redirected to the CodePlex home page.

Interestingly, when I open FireFox I do not have this problem.  I can see the project's home page.

Apparently the problem only exists in my primary browser: IE 9 (version 9.0.8112.16421).  I guess it's a cookie issue.


Apr 2, 2011 at 9:03 PM

Signing out of CodePlex doesn't even solve the problem in IE 9.  I'm still redirected to the CodePlex home page instead of seeing the project's parking page.

Apr 2, 2011 at 9:06 PM

Restarting IE 9 doesn't help either.  (I made sure that no iexplore.exe processes were running in Task Manager before starting IE again.)

Apr 2, 2011 at 9:10 PM

Deleting the cookie and restarting IE 9 does not solve the problem.  I'm still redirected to when I browse to my project in IE 9, but not in FireFox.

What a strange issue :)


Apr 2, 2011 at 9:19 PM

Deleting all of my "live" cookies (which I use to sign in to CodePlex) and restarting IE 9 does not solve the problem either.

Apr 2, 2011 at 9:23 PM

Signing in to CodePlex with my CodePlex account credentials instead of using the Live service does not solve the problem either.

I'm not going to delete all of my cookies, so if it's a cookie issue can somebody please tell me which ones I need to delete?


Apr 3, 2011 at 2:37 AM

Very strange, I've never heard a report of this problem before.  I tested your new project URL from IE 9 on multiple machines and they all worked properly.  Do you have any add-ins installed?  Maybe tried disabling them and see if that makes a difference.

Apr 3, 2011 at 5:23 AM


Thanks for replying.

I don't think I have any add-ins installed besides Flash and some spell-checker from 1975 ;P  They've never caused any problems like this before.

I've been using FireFox all day to work on the project without any issues, so it must be an IE 9 issue.

Ok, on a hunch I decided to append some garbage to the URL in case there was a caching issue, and that worked!  If I add a question mark (i.e., an empty query string) to the root project URL then it loads in IE 9.  However, if I change it back to the normal root project URL (, then I'm still being redirected to the CodePlex home page.

Clearing my temporary Internet files in IE 9 doesn't help.  So weird.  I'll try restarting my computer later to see if that helps.


Apr 3, 2011 at 8:54 PM
Edited Apr 3, 2011 at 8:54 PM

Where did you get the link  I tested your new project url as well and it is a different name / url and it worked as expected.


Apr 3, 2011 at 11:14 PM

Hi Colin,

It was just a URL format example, sorry for the confusion.  I should've just used the real project name.  So to be clear, the following two links do not work for me in IE 9 - I get redirected to

Although they work in FireFox.  Furthermore, URLs to different places in my project work fine in IE 9; e.g., the Documentation tab, Source Control tab, etc.

To see my project's home page using IE 9 I must change the URL by adding a benign "?" character at the end.  I was able to edit the project's home page with this "?" hack, but when I click save I'm redirected to

Given that two completely different URL formats aren't working, I'm beginning to think that caching and IE 9 might not be the problem, unless I was just really unlucky twice ;)

Haven't had time to restart my computer (takes too long :P) but I'll get back to you when I do.

- Dave

Apr 5, 2011 at 2:24 PM

Restarting my computer didn't solve the problem.  I'm running out of options :)

- Dave

Apr 5, 2011 at 2:51 PM

Can you e-mail us using our Contact Us form?  I'd like to see if you can send us a Fiddler trace to try and diagnose what's going on.

Apr 5, 2011 at 4:14 PM

Sent, thanks.

- Dave

Apr 8, 2011 at 4:34 AM


It works now!

I had just opened my browser tonight and entered the base URL - but it didn't work; as usual, it redirected me to the CodePlex home.  But then I used the "?" hack so that I could edit my project's home page.  I edited the Project Summary & Details first (not the wiki, the link) and when I clicked Save this time I was redirected to the project's home page - not the CodePlex home page like it usually does.

Somehow that seems to have fixed the problem, unless it's just coincidence.  Now I can consistently go to my project's home page URL in IE 9 without the "?" hack and I'm not redirected to the CodePlex home page.

Did the CodePlex team change any cache settings perhaps?  Or has IE 9 simply self-corrected?