TF14098: Access Denied

Dec 27, 2010 at 11:16 AM
Edited Dec 27, 2010 at 11:38 AM

Hello,

I (the project coordinator) am suddenly unable to checkin any changes and am getting the error

'TF14098: Access Denied: User SND\saphua_cp needs Checkin permission(s)'

What could be causing this?

 

Edit: Never mind, it's working again! Don't know what the cause was though.

Dec 27, 2010 at 2:14 PM

I was getting intermittent access denied errors connecting to TFS01 as well, but I tried reopening the solution in Visual Studio and now I'm getting consistent source code binding errors...

The error in the output window is: "One or more source control bindings for this solution are not valid".  And in "Change Source Control..." the status is "Invalid".  This was previously working just fine and I have not made any changes; the problem seems to be the TFS server.

Dec 27, 2010 at 7:19 PM

I'm getting similar errors too. It's very temperamental and intermittant with no clear reproduction steps, but whenever I try to do anything like check-out or check-in a change, or lock a file I get messages like these:

 

---------------------------
Microsoft Visual Studio
---------------------------
Error

TF14098: Access Denied: User SND\W3bbo_cp needs Checkin permission(s) for $/anolis/Anolis.Tools.ImageTools/Anolis.Tools.ImageTools.csproj.vspscc.
---------------------------
OK  
---------------------------

I can't figure it out, and it's very stressful because sometimes I can do stuff, other times I can't and I get Access Denied for something else.

FWIW I'm on https://tfs.codeplex.com/tfs/TFS03

Dec 27, 2010 at 8:12 PM

I was able to repro this issue and I believe I have resolved it.  Can you tell me if you run into any more problems?

Thanks,
-Colin

Dec 28, 2010 at 3:47 PM

Thanks Colin, that seems to have fixed it.

Pray tell, what was the cause of the problem?

Dec 28, 2010 at 5:49 PM

One of the servers in our TFS farm was having intermittant issues with project permissions.

Thanks,
-Colin

Dec 29, 2010 at 5:00 AM
Edited Dec 29, 2010 at 5:00 AM

I've been getting this intermittently over the last several days. Sometimes switching to SVN lets me commit, sometimes it doesn't. Its actually happening right now with the Rawr project so I can't make commits with either TFS or SVN and we're trying to get a new release build out.

Jun 14, 2013 at 7:53 AM
Hello, this same issue appears once again (TFS34). My developer (with his permissions) can't checkin file.
Other problem is the all files after checkin locks (and i need to check out all of them).
Jun 14, 2013 at 6:24 PM
@puradawid: Are you still having an issue? Could you please elaborate a bit more?