Internal error during begin publish.

Mar 3, 2008 at 10:52 PM
I am reciving the following error. My hosting provider says their system is fine and that its on my side. What does this error mean.



Internal error during begin publish. (System.Web.Services)

Program Location:

at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.SqlServer.Tools.HostingServices.PublishService.BeginPublish(String serverName, String databaseName, String sqlUsername, String sqlPassword, Boolean useTransactions)
at Microsoft.SqlServer.Management.SqlManagerUI.Scripting.WebServicePublishOptions.Initialize(String databaseServerName, String databaseName, String databaseUserName, String databasePassword)
at Microsoft.SqlServer.Management.SqlManagerUI.Scripting.WebServicePublishOptions..ctor(Uri webServiceAddress, String webServiceUsername, String webServicePassword, String databaseServerName, String databaseName, String databaseUserName, String databasePassword)
at Microsoft.SqlServer.Management.SqlManagerUI.OutputOptionsWizardPage.OnLeavePage(LeavePageEventArgs e)

Mar 8, 2008 at 1:55 AM
same issue.Trying to use it with godaddy
Mar 9, 2008 at 1:44 AM
I haven't made any progress with this error and importing directly to godaddy, but perhaps this solution is adequate for other's needs also. Instead of importing directly into the godaddy, use the database publishing wizard to create a script of your database. Then split the script file into < 2.5 MB files, open the files in godaddy's query analyzer and then execute the scripts. If your database isn't huge that should work okay. Why they would impose a 2.5 MB size limitation is beyond me, but they seem a little ass backwards at times over there. Let me know if you have any questions or if you come across a better solution.
Mar 12, 2008 at 12:29 AM
This is one of the last things I've tried without success:

1. Generate a script with the schema only from my local database
2. Copy and paste script into query analyzer of the SQL manager (to duplicate the database without data)
3. Backed up the database and downloaded the backup.
4. Restored the backup in a new database on my local machine
5. Imported data into new backed up database
6. Backed the new database to the original backup file
7. Uploaded the new backup file (with the same name) back to the server
8. Restored the database

It failed on step 8 because of some security settings put it place to only allow restoring backups created by that particular machine. If anyone knows of a way to hack the files to fool the server, that would be very beneficial. That's the last thing I've tried. Now I am just trying to rally support to get everyone that is having problems to contact technical support ( so they acknowledge there is a problem on their end.
Mar 12, 2008 at 5:23 PM
GoDaddy fixed the problem. We're back in business. I've tried it and I am currently sending my database up to the server. Its all good.