Connection to upgraded server fails

Jul 23, 2010 at 3:01 PM
Edited Jul 23, 2010 at 3:06 PM

By the information on the Source Code page, my project server is upgraded. I have updated my VS 2008 Team Explorer.

But using the new connection information on the Setup page, the connection fails with the following dialog message...

---------------------------

Microsoft Visual Studio

TF31002: Unable to connect to this Team Foundation Server: tfs.codeplex.com.

Team Foundation Server Url: https://tfs.codeplex.com:443.

Possible reasons for failure include:

- The Team Foundation Server name, port number or protocol is incorrect.

- The Team Foundation Server is offline.

- Password is expired or incorrect.


For further information, contact the Team Foundation Server administrator.

---------------------------

OK Help

---------------------------

What is going on here?

Best regards,

Paul.
Jul 23, 2010 at 6:57 PM

Hi,

I have the same issue. Did you find a solution ?

 

Best regards,

Thomas.

Jul 23, 2010 at 7:01 PM

The correct URL that you should use is https://tfs.codeplex.com/tfs

Matt

Jul 24, 2010 at 12:07 AM
Hello Matt,

This brings out another error...

Microsoft Visual Studio

TF30335: The server name cannot contain the characters '/' or ':', or start with 'http://' or 'https://'.
If the server name is an IPv6 address, it can contain the character ':' only if the full name is enclosed by square brackets.
---------------------------
OK Help ---------------------------

Best regards, Paul.

Jul 24, 2010 at 1:36 AM
Hello Thomas,
As you can tell, the problem is still unresolved..

Best regards,
Paul.

Jul 24, 2010 at 1:53 AM

My projects are in the TFS09 collection and I'm able to access it using VS2010.  I've applied the fwd compat update to VS2008 but I still can't access.  I was at first get the TF31002 error but now that I put in the URI https://tfs.codeplex.com/tfs I get the error message  TF31003: Your user account does not have permission to connect to the team foundation server.

I know I'm using the correct domain\user and password and that I can connect using VS2008.  Anyone have any thoughts on how to resolve this?

Jul 24, 2010 at 1:55 AM
Edited Jul 24, 2010 at 1:56 AM

Using Team Explorer 2008 make sure you type in the full server path with collection name when you add a new server: https://tfs.codeplex.com:443/tfs/TFS09.

Thanks,
-Colin

Jul 24, 2010 at 1:57 AM

Thanks, I just figured that out when I looked at the instructions listed under "Team Explorer Everywhere".   It would be really great if they could list that under the "Team Explorer" section. :-)

Jul 24, 2010 at 2:56 AM
Edited Jul 24, 2010 at 3:10 AM
SelormeyPaul wrote:
Hello Matt,

This brings out another error...

Microsoft Visual Studio

TF30335: The server name cannot contain the characters '/' or ':', or start with 'http://' or 'https://'.
If the server name is an IPv6 address, it can contain the character ':' only if the full name is enclosed by square brackets.
---------------------------
OK Help ---------------------------

Best regards, Paul.

I got the same error when typing https://tfs.codeplex.com:443/tfs/TFS06 in the Add Server form.

I also didn't notice any change on the VS2008 "connect to TFS" windows, before and after the compatibility patch. Should the form be different now ?

Maybe the patch didn't installed well on my configuration (although I got the "success" confirmation, but we never know....)

I can connect to the Team Web Access (https://tfs.codeplex.com/tfs/) and find my project, so at least, it is not a login / password issue ...

Thanks in advance,

Thomas.

 

 

Jul 24, 2010 at 7:48 AM

>>Thomas: I can connect to the Team Web Access...

Same here. A search on the internet of the TF30335 error led to...

http://netrsc.blogspot.com/2009/11/tf30335-connecting-visual-studio-2008.html

Changing the registry according to that blog, now results into an different error TF253022, saying the Forward Compatibility Update must be installed.

Best regards,
Paul

Jul 24, 2010 at 12:31 PM
Edited Jul 24, 2010 at 12:39 PM

Hello Thomas,

The Team Server sucks, my boss gave up on it and I almost gave up after spending the whole day trying to figure how to access my source codes!

This is how I finally got it working...

  1. Re-install the Team Explorer 2008
  2. Re-install the VS 2000 SP1
  3. Re-install the Forward Compatibility Update
  4. Go to the Registry, and navigate to the HKEY_CURRENT_USER/Software/Microsoft/VisualStudio/9.0/TeamFoundation/Servers
  5. Add a string type value, set the name to tfs.codeplex.com and the value to https://tfs.codeplex.com/tfs/TFS06, depending on your project settings
  6. Start the VS 2008, and login into your project.

NOTE Please follow that order, while making sure the VS.NET 2008 is not opened, until completed.

Hope this helps.

Best regards,
Paul.

Jul 24, 2010 at 12:46 PM

Hello Paul,

Thanks for the solution !

I have been much more lazzy I just upgraded to VS2010 (MSDNAA ruleZ ! ).  But I'll try this later !

Thank you again,

Best Regards,

Thomas.

Jul 24, 2010 at 4:30 PM

It would have been nice if the dialog in team explorer 2008 had been updated to show the additional configuration options however it's totally not required to go into the registry.   Once you start typing into the server field all of the other controls become disabled and the server field basically becomes a URI/URL field.  Not the best UI design in the world but it does work once you get someone to explain the behavior ( which should be more obvious but ohwell... )

Aug 6, 2010 at 7:26 AM
chrpai wrote:

It would have been nice if the dialog in team explorer 2008 had been updated to show the additional configuration options however it's totally not required to go into the registry.   Once you start typing into the server field all of the other controls become disabled and the server field basically becomes a URI/URL field.  Not the best UI design in the world but it does work once you get someone to explain the behavior ( which should be more obvious but ohwell... )

What he said! Thanks to @matthawley for pointing me to this thread, using the full URL worked for me as well. Though it would be nice if I could just use tfs.codeplex.com to see all my projects listed on all servers, but that's probably discussed in another thread somewhere :D

Aug 6, 2010 at 6:02 PM

I also had this issue. Both with the TF31002 and TF30335 errors. It seemed like the compatibility patch was not installed correctly or something. However, I followed SelormeyPaul's description step 1, 2 and 3 (did not need the rest), started up VS 2008 and entered https://tfs.codeplex.com/tfs/TFS01 into the server add dialog. The buttons grayed out and I could login successfully.