Repository UUID changed?

Jul 20, 2010 at 10:59 PM

I was trying to update a few projects and got UUID mismatch on several - but not all of the projects


Command: Update 
Error: Repository UUID '9b283d60-5439-405e-af05-b73fd8c4d996' doesn't match expected  
Error: UUID '25d8fd2b-6a69-44ad-a716-4a7b2595fe98' 


Repository UUID 'a83551a4-30f6-4d81-a974-c6ced450ddbf' doesn't match expected
UUID '8ead0314-7f71-49e1-95c8-3147638646d4'and

MVVM Light

Repository UUID '9b283d60-5439-405e-af05-b73fd8c4d996' doesn't match expected
UUID '25d8fd2b-6a69-44ad-a716-4a7b2595fe98'

 Not I can checkout the projects; just can't update the ones I have in my HD


Jul 21, 2010 at 12:06 AM

Same here with Caliburn.  I haven't tried any others.

Jul 21, 2010 at 6:51 AM

Those projects were migrated to our new TFS2010 servers this week and you will need to perform a fresh checkout to resolve this issue.  Sorry for the trouble.


Jul 22, 2010 at 12:41 AM
Ummm. I CANNOT do a fresh checkout of Caliburn. I have a massive amount of uncommitted changes. I was in the middle of a major refactoring! What am I supposed to do?
Jul 22, 2010 at 1:26 AM
Ok. If you can do a fresh checkout, I recommend that. But, if you are in a similar situation as me, you may want to look at this:
Jul 28, 2010 at 11:54 AM

I was in the same boat, your link saved me a lot of time, thanks.

Jul 31, 2010 at 7:55 PM
Edited Jul 31, 2010 at 7:56 PM

I had the same problem - needed to commit without getting latest, so you can get around this by doing a replace:


find /home/Code/MyProjectFolder -type f -exec sed -i 's/OLDGUID/NEWGUID/g' {} \;

Aug 3, 2010 at 3:21 PM
Thanks for the pointers on fixing this.
Sep 11, 2010 at 10:01 PM
Edited Sep 11, 2010 at 10:03 PM


If you are using TortoiseSVN (IMHO any SVN client which stores its data in .svn subfolders) ant Total Commander (no sorry, no Windows Explorer) this issue can be solved this way:

Assuming that your repository folder is named "Repository"

  1. Goto Total Commander settings | Functions \ Ignored files and add .svn
  2. Rename your repository folder to "Repository-old"
  3. Create a new folder called "Repository"
  4. Checkout SVN repository to newly created folder
  5. Using Total Commander (F5) copy all content of "Repository-old" to "Repository"
  6. Commit changes in "Repository"
  7. Delete "Repository-old"

The trick is that Total Commander does not overwrite .svn directories when they are ignored. It just overwrite all other files, so your local changes are preserved (unless you have done file operations like move, rename, delete).

Note: You need one of latest versions of Total Commander. The Ignored files feature is relatively new.