Connection Via TortosieSVN

Jul 14, 2010 at 12:09 PM

I've got a little frustrated at trying to get SVN to work and have no idea what I'm doing wrong. I thought it was a firewall in the office blocking it, fair enough, so started trying at home and get exactly the same error.

I'm trying to connect to some source on codeplex. I've tried the main branch [https://hg01.codeplex.com/greatmaps] and I've also tried my fork [https://greatmaps.codeplex.com/forks/ianwright83/serializableclasses] that I create through the site. Literally by going to repository browser using TortoiseSVN and pasting in those URLs.

At home I disabled my firewall, and just have a router (with your standard setup) that connects me to the Internet. Tortoise constantly gives me the error:

The OPTIONS response did not include the request activity-collection-set; this often means that the URL is not WebDAV enabled

The main developer who leads the project can access it fine, so can lots of other people. Question is why can't I? I've googled the error and all I come up with is stuff about proxy servers causing problems. I don't think I'm behind a proxy in either location (actually have no idea how to set one up).

Can anyone point out to me where I'm going wrong because I literally have no idea what to do now?

Thanks very much.

 

Jul 15, 2010 at 12:39 AM

Hi Ian,

Greatmaps is a Mercurial project so you will need to download a HG source control client, such as TortoiseHG, to access the source code.

Thanks,
-Colin

Jul 15, 2010 at 7:08 AM

Colin,

Thank you. I have no idea what a Mercurial project is but I will give that a try. If I get stuck I might post some follow up questions here if that's alright?

Thanks,

Ian

Jul 20, 2010 at 7:21 AM

Colin,

Using an online tutorial I managed to clone the repository from [https://greatmaps.codeplex.com/forks/ianwright83/serializableclasses] to a local folder. I then made the changes I required and use the 'HG Commit' option in tortoise HG. What I don't quite understand though, is that the 'repository history' option or similar in tortoise HG has a log of the changes I've made. If I goto the webpage for the fork however [https://hg01.codeplex.com/forks/ianwright83/serializableclasses] then none of these commit's and their comments appear in the change log... am I doing something wrong?

 

Thanks,

Ian

Jul 20, 2010 at 7:48 AM

Hi Ian,

Mercurial treats commits differently than SVN. Commits are local only until you "push" them to the central repository. Use the Synchronize dialog to push your changes (or from the command line, run hg push from that directory).

Matt

Jul 20, 2010 at 12:27 PM

Thanks for your help guys. I think I've got it now. Then just finish off with a 'pull request' for the project lead to merge that into the main branch I'm assuming...?

 

:)

Jul 20, 2010 at 1:32 PM

Exactly