Cannot connect to TFS

Feb 2, 2008 at 6:17 PM
I am a new user, and have just created a new project. However, I am unable to connect to the TFS server from Team Explorer. Here's what happens when I try to do it from the command line:

>tf workspace /new /server:https://tfs05.codeplex.com /login:snd\UID_cp,PWD
Team Foundation Server https://tfs05.codeplex.com does not exist or is not accessible at this time.
Technical information (for administrator):
TF50309: The following account does not have sufficient permissions to complete the operation: SND\UID_cp. Check the permissions for the account and grant the appropriate permissions to perform this operation.

I put my actual info where you see UID and PWD above. What am I doing wrong?
Feb 2, 2008 at 6:19 PM
When I try the same thing from within Team Explorer, I get this error message:

TFS31003: Your user account does not have permission to connect to the Team Foundation Server https://tfs05.codeplex.com:443.
Feb 5, 2008 at 5:27 AM
It takes a little while after creating a project before it is ready on the source control server. So if you try to connect immediately after creating the project then you'll get that message.
Feb 10, 2008 at 12:49 PM
I was wondering how long a little while is...
I created a new project about an hour or 2 ago and when i try to connect using Teamprise Explorer i also get the TF50309 error.

When i try to connect via https://tfs05.codeplex.com/services/v1.0/registration.asmx that does work.
Feb 10, 2008 at 9:54 PM
I just checked on your project and found a permissions issue. Try it again and it should work fine for you now.
Feb 13, 2008 at 2:02 AM
I'm having the same problem with my project. My project was created about a day ago and I still can't log in.
Feb 13, 2008 at 6:11 PM
Cameronm, try it again and it should work for you now.
Feb 27, 2008 at 4:18 AM
Hi, i´m having the same problem. But in my case, I try open one existing project "openbravodotnet" using the address "https://tfs06.codeplex.com", but I receive the message "Your user don´t have permissions to connect to Team Foundation Server...". Can you help me?
Mar 11, 2008 at 5:42 AM
Everything with your project seems fine. Is it working for you now? Were you trying to connect shortly after creating the project? Sometimes it takes a little while before the project is ready in TFS.
Jun 30, 2008 at 2:19 PM
Hi... I'm having the same problem. My latest project was created a few hours ago. BTW, could you check permissions for all 3 of my projects (1 public, 2 hidden)? I plan to publish all of them tomorrow (and upload source files).
Jul 2, 2008 at 4:12 AM
I created a project yesterday, and today I tried to connect to TFS to upload my source code. Sadly, the message "Make sure that the machine name and path are valid" was displayed. I tried to ping the server address but it failed. I tried to connect to the server through the browser and It worked (the message Directory Listing Denies was displayed). Theres no proxy configured for the browser. Any ideas on the error cause?
Sep 10, 2008 at 12:50 PM
I'm having the same issue as well.  "Your user account does not have permission to connect to the Team Foundation Server https://tfs08.codeplex.com:443..."  I created my project last night.  Any help would be appreciated.
Sep 10, 2008 at 11:50 PM
Same here, created a project, waited a while, tried many times to connect Team Foundation Server.  TF31003 every single time, with no obvious way forward at my end.
Sep 11, 2008 at 5:58 PM
Hi, does anyone important read this forum?  This is a complete show stopper, I still can't access my project.  There's nothing I can do about it from here.  Actually it was just a test project so I could investigate TFS etc.  Looks like the test failed...  Also, is there no way to have read only access to other projects using this team system VS thing?  It's lame that I have to use an entirely different method for that.
Sep 11, 2008 at 6:53 PM
Sorry about the trouble, I've fixed your project now.  We do monitor this forum, but the fastest way to receive support is through the Contact Us form.  Let us know if you need anything else.
Sep 11, 2008 at 7:17 PM
Many thanks, it works now.
Sep 25, 2008 at 9:30 PM
I am also suffering connection issues. No combination of user name (with or without the suffix & prefix) will allow me to connect.
Please help
Oct 1, 2008 at 7:32 PM
This is very common error, all you need to do is to ask people to add you as a user to TFS which is normally done via WSS.
Oct 4, 2008 at 5:41 PM
Same problem here. New user and project. Cannot connect to TFS. "The following account does not have sufficient permissions to complete the opertion"
Apr 22, 2009 at 12:58 PM
I have the same problem with newly created project "librarian".
Apr 23, 2009 at 5:03 PM
LostTheBlack,

The permissions look setup correctly on the project librarian now.  If you are using Team Explorer to connect, are you using SND\LostTheBlack_cp as your username to login?
Jan 27, 2010 at 10:32 PM
Edited Jan 28, 2010 at 4:06 PM

I was earlier able to connect with Team Explorer 2008, but we complete transferred to Visual Studio 2010. However when I try to connect with tfs08.codeplex.com I get the TFS31002 error for project NetDns and username 'snd\swordfish_cp'. Is it possible that my project have to move to another TFS server to be able to connect with a TFS2010 server?

p.s Just to be clear: It doesn't matter what I put in the 'Path' property. I keep getting the TFS31002 error. I'm using VS2010B2 Premium to connect.

 

 

Edit: Fixed some typos.

Apr 21, 2010 at 7:02 PM

Hi!

Currently running VS 2010 on Win7 and I cannot connect to tfs05.codeplex.com.

Just says

HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.Internet Information Services (IIS)
--------------------------------------------------------------------------------

in IE8

and

---------------------------Microsoft Visual Studio---------------------------

TF31003: Either you have not entered the necessary credentials or your user account does not have permission to connect to the Team Foundation Server at https://tfs05.codeplex.com/. Click the Use different credentials link below, or ask your server administrator to add the appropriate permissions to your account

.---------------------------OK   ---------------------------

 

in VS 2010 TE

 

 

Login: snd\AlexSorokoletov_cp.

 

Connecting to this site from ubuntu/Chrome is okay.

Also from other computers with windows & VS 2008/2010

 

Can anyone help?

Alex.

Aug 5, 2010 at 8:46 PM
Edited Aug 5, 2010 at 8:46 PM

I can not ping (from command prompt)  server and connect my project (from team explorer) to check in code for first time. It's more thamn a week I have created a project

Aug 5, 2010 at 8:47 PM

shippu,

What is your project name?

Thanks,
-Colin

Aug 23, 2010 at 7:14 PM

Hi,

even i am having the same issue. Its been almost 12  hrs. Can any1 help me?

 

Regards,

Poojith

Aug 24, 2010 at 1:39 AM

Poojith,

What project are you trying to connect to?  And what version of Team Explorer are you using?

Thanks,
-Colin

Dec 15, 2010 at 8:19 PM

Hi,

the same here: I've created a project before some hours.

TFS URL: https://tfs.codeplex.com:443/tfs

Error: TF31003: Either you have not entered the necessary credentials or your user account does not have permission to connect to the Team Foundation Server at https://tfs.codeplex.com/tfs.

For the credentials I use my codeplex username and password.

I use VS2010 Professional with the integrated Team Explorer.

Any suggestions?

Thx!

Ingo
http://ikarstein.wordpress.com

Dec 17, 2010 at 3:36 PM

ikarstein,

Make sure you use your TFS username: SND\ikarstein_cp

Thanks,
-Colin

Dec 17, 2010 at 4:29 PM

I created my project yesterday afternoon and both the Source Code and Issue Tracker aren't up yet. Even though the tracker says it should be ready a few hours after I create the project.

Dec 21, 2010 at 6:33 AM

Codester1,

This issue has been resolved.

Thanks,
-Colin

Dec 28, 2010 at 3:29 PM

Hi Colin!

It works now! - I'll update my SharePoint project soon :-)

 

Kind regards
Ingo